Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google


No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.

The new forum is at:

The new forum is running IP.Board and will be our primary forum from now on.

This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.

Thank you,

M4: Lossing shares on WHS 2011 restart

edited January 2012 in DrivePool
Deceided to take the Plunge last night and give M4 a go. I followed the instructions and the installation was slick. Rebooted the server and saw that the pooled shares had gone. I have since reinstaed them in a number of ways but they still seem to get dropped on a reboot. Read a few posts but none of the suggested solutions seem to have worked for me.


  • I'm having the same exact issue. I recreated the share after install, but after each reboot, the shares are gone and I have to recreate. Any fixes for this?
  • I have just upgraded to 5421 which in the change log indicates some changes have been made to address this.

    Well as soon as I rebooted the shares have been lost and I have had to manually recreate in 5421. I have then rebooted again to confirm that they have not been retainined. The change log suggested that some changes had been made although the fault was unreproducable at Alex end.

    I have tried redoing the share using the different methods mentioned in the various posts on this subject but the way I do it most often is from the dashbaord... Under server folders I click add folder. I then browse to my pooled drive where all the pooled folders seem to be sitting at the root so I:\dvds etc. The I grant RW access to everyone. The share then remains in place until the next reboot.

    I have also tried a full uninstall and reinstall of DP. Immediatley the shares were made available but were lost again after a reboot?

  • edited January 2012 Member
    Same error here. All Drivepool shares are gone after a reboot. Maybe there is a timinig problem that the shares are established before the Covefs drive comes online?! My WHS Server uses slow hardware (that caused problems with M3 and before).

  • My shares come up fine, but I have major hardware overkill.
  • When reestablishing a share on the pool (one which will get lost in a restart), the windows event display will show

    Protokollname: Application
    Quelle:        VSS
    Datum:         16.01.2012 18:01:22
    Ereignis-ID:   12289
    Ebene:         Fehler
    Benutzer:      Nicht zutreffend
    Computer:      Twihomeserver
    Volumeschattenkopie-Dienstfehler: Unerwarteter Fehler "DeviceIoControl(\\?\Volume{f13f3687-3fb6-11e1-a306-00151731b275} - 000000000000012C,0x00530024,0000000000000000,0,000000000034D600,4096,[0])". hr = 0x80070001, Unzulässige Funktion.
    <Event xmlns="">
        <Provider Name="VSS" />
        <EventID Qualifiers="0">12289</EventID>
        <TimeCreated SystemTime="2012-01-16T17:01:22.000000000Z" />
        <Security />
        <Data>DeviceIoControl(\\?\Volume{f13f3687-3fb6-11e1-a306-00151731b275} - 000000000000012C,0x00530024,0000000000000000,0,000000000034D600,4096,[0])</Data>
        <Data>0x80070001, Unzulässige Funktion.

    It concerns the shadow copy function which is not possible on a pool drive. I don´t know wether this is the cause or just an anticipated side effect.

  • edited January 2012 Member
    Same error here. All Drivepool shares are gone after a reboot. Maybe there is a timinig problem that the shares are established before the Covefs drive comes online?! My WHS Server uses slow hardware (that caused problems with M3 and before).

    Exactly what i thought. I think WIndows try's to create the shares before the Drivepool drives are ready.

    I have 3 different SATA controllers, with a total of 12 drives. So booting ain't fast.

    Maybe a longer timeout or some kind of auto retry could fix this...
  • Well the longer timeout would have to be on the windows side and that might not be easy to bring about. Lets see what Alex has to say...
  • I have the exact same problem, looking forward to Alex doing some magic on this issue..
  • Have now upgraded to 5472.

    • However removed the add-in first.
    • Rebooted
    • Then in the registry I stripped out any entries left with covefs, I: (My Drivepool virtual drive) and drivepool in
    • Rebooted
    • Installed 5472
    • Rebooted
    • Setup the drivepool shares in the dashboard with everyone full control
    • Rebooted

    But alas the shares have been dumped at reboot again. Any ideas?

    One share, Pictures, is a WHS default share and I remapped this to i:\pictures but on reboot the dashboard showed that the share was missing. Looking at the path it wanted it was looking for i:\serverfolders\pictures

    Is this the issue?

  • Alex is working on the problem... Somehow the pool directories are not listed during boot on slow systems so shares are dumped on reboot.
  • Thanks for the update. What consitutes a slow system?

    Granted my MB is not the most recent and based on an Intel Core 2 6700@2.7GHz with 4Gb of Ram

  • Hmm that is in WHS terms most definitely NOT a slow system :-) Maybe the problem has nothing to do with system performance after all, we will see...
    I'm having exactly the same Issue, My computer is a Athlonx2 2.8 Ghz with 6 gb RAM and running with little CPU and MEMORY.

    Any way we can help to solve the issue?
  • edited January 2012 Member
    Alex just resolved this issue with build: 5536 !.. YAY!

  • Alex,

    Great work and thanks for the fix. Just tried 5536, rebootted and there are the shares as I left them.

    Great work alex,

    I have check it this morning and everything is working perfectly and not any share is lost. Thanks for your work.
Sign In or Register to comment.