Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Our Sites 


No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.

The new forum is at:

The new forum is running IP.Board and will be our primary forum from now on.

This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.

Thank you,

Duplication cannot be activated on some folders

edited May 2013 in DrivePool
I have problems activating duplication on some folders of a pool, while others work properly.
I have tried with the UI, and it pops up an error.
Then I have tried with the command line (F: is my pool), and it gives me that:

F:\Media\Music>dpcmd set-duplication Keep 2
ERROR: Can't set duplication count on the pool. (Access is denied)

Do you have any idea where that can come from?
Just to let you know, I have write access to this folder and its content.
The access rights are inherited from F:\

Any suggestion appreciated ;)


  • edited May 2013 Member
    I have added F:\Media\Music to my indexed locations...
    Could it come from that?

    Edit: Just tried to remove the folder from the indexed locations, does not change anything.
    By the way, I have duplicated with success this folder: F:\Media\icons
    This one is hidden and has exactly the same inherited access rights than the problematic one.
  • Member
    Very strange, setting duplication to 2 for folder F:\Media\Music fails as well.
    When doing so for folder F:\Media it works!
  • Member
    Hi Drashna, I have nothing in C:\ProgramData\StableBit DrivePool\Service\ErrorReports
  • Covecube
    That's... very odd.

    If that's the case, then try this: 
  • Member
    Hi Drashna, thanks for the feedback.
    I am using server 2012, and to be honest not very familiar with it.
    In the link you give, there is something to do in Windows Home Server 2011 Dashboard.
    I do not know how to translate that to Server 2012.
    When I go to the dashboard, I do not see a 'Server Settings' entry ...
  • edited May 2013 Member
    By the time, I do not know if this might be useful but here is a dir of my folders displaying alternate data streams.
    Here is as well the data streams contents for the folders that are of interest:

    H:\Media\Music>more < H:\Media:DuplicationCount.Tag.CoveFs:$DATA
    H:\Media\Music>more < H:\Media\Music:DuplicationCount.Tag.CoveFs:$DATA1
    H:\Media\Music>more < H:\Media\Music\Keep:DuplicationCount.Tag.CoveFs:$DATAThe system cannot find the file specified.
    H:\Media\Music>more < H:\Media\icons:DuplicationCount.Tag.CoveFs:$DATA2

    Couldn't it be H:\Media\Music  that has a value of 1 causing a problem?
  • edited May 2013 Member
    Finally I got rid of it...
    Renamed H:\Media to H:\Media_old
    Then recreated H:\Media from scratch, with all the structure and setting appropriate duplications.
    Finally copied the files from the old location, and deleted it.
    That worked this time, but this is kind of scary if this bug happen with the pool filled up...
  • edited May 2013 Resident Guru
    From the "Access is denied" error mentioned earlier, I would be suspecting something messed up the NTFS ownership/permissions (and I've seen Windows claim "yeah all is good and you've got full rights to this file" when even System can't touch it and fixing required accessing the drive from a bootable CD).
  • Member
    Yes Shane, I had the same idea.
    I even tried reforcing the access rights but nothing worked...
    For now it seems ok, I hope it will not happen again with the drive filled :/
  • Member
    Ok, seems that duplication is critically buggy...

    Tried to activate duplication on a subfolder of a non duplicated one through the Gui.
    Does not pop-up any error, but the folder stays with a x1 picture.
    Then I try to do it by hand, deleting the folder and recreating it, and look what happens:

    H:\Applications>dpcmd set-duplication Drivers 1
    Duplication count set to 1 on 'Drivers'.

    H:\Applications>dir /R
     Volume in drive H is DrivePool
     Volume Serial Number is 19DE-A63E

     Directory of H:\Applications

    22/05/2013  20:09    <DIR>          .
    22/05/2013  20:09    <DIR>          ..
                                      4 ..:DuplicationCount.Tag.CoveFs:$DATA
                                     48 ..:PoolId.Tag.CoveFs:$DATA
                                      8 ..:ProtectedLimit.Tag.CoveFs:$DATA
                                      8 ..:UnprotectedLimit.Tag.CoveFs:$DATA
    22/05/2013  18:49    <DIR>          Games
    22/05/2013  20:09    <DIR>          Drivers
                                      2 Drivers:DuplicationCount.Tag.CoveFs:$DATA
    22/05/2013  18:47    <DIR>          Operating Systems
    22/05/2013  19:26    <DIR>          Tools
                   0 File(s)              0 bytes
                   6 Dir(s)  1 709 072 236 544 bytes free

    H:\Applications>more < Drivers:DuplicationCount.Tag.CoveFs:$DATA

    H:\Applications>dpcmd set-duplication Drivers 3
    Duplication count set to 3 on 'Drivers'.

    H:\Applications>more < Drivers:DuplicationCount.Tag.CoveFs:$DATA

    No matter what I do now, the count stays at 2...
    That kind of scary me, I am trying this tool since less than one week and the duplication thing is completely unstable.
  • Member
    Apprently, the ADS DuplicationCount.Tag.CoveFs:$DATA was missing for parent folder.
    I copied the one of another nearby folder and it fixed the thing (see for tools to manipulate ADS).
    Can someone from the official DP team tell me if that would make the trick or if it may break the whole thing?
    I hope these kinds of bugs will be fixed...
  • edited May 2013 Covecube

    Regarding your example above. I believe your confusion has to do with the use of "more" to read the duplication tags.

    Here is an example that shows why:

    G:\Dup1>dpcmd set-duplication Dup2 1

    Duplication count set to 1 on 'Dup2'.

    G:\Dup1>type Dup2:DuplicationCount.Tag.CoveFs:$DATA
    G:\Dup1>more < Dup2:DuplicationCount.Tag.CoveFs:$DATA

    G:\Dup1>dpcmd set-duplication Dup2 2

    Duplication count set to 2 on 'Dup2'.

    G:\Dup1>type Dup2:DuplicationCount.Tag.CoveFs:$DATA
    G:\Dup1>more < Dup2:DuplicationCount.Tag.CoveFs:$DATA

    As you can see the duplication tags are actually written correctly, but "more" does not see the change. You can also open up the tags in notepad to confirm this:

    notepad Dup2:DuplicationCount.Tag.CoveFs

    Just don't edit them.


    Regarding the access denied error, it could be that some parent folder was missing the proper SYSTEM permission in order to write those tags.


    I'm not entirely sure what you're saying about the parent tag being missing.

    When you set a duplication count on a folder, DrivePool will go ahead and set tags on every parent folder of that folder (if they're not set already) to inform all the parent folders that one or more sub-folders has an explicit duplication count set.

    The parent folders will be typically set to "MI", indicating that the folder has multiple duplication counts under one or more sub-folders, and that it itself is inheriting its duplication count from its parent.

    Can you confirm that this is somehow not working for you (don't use more)?

    As far as I know everything should be working correctly, and I can't reproduce any problems with this over here. But if you do find an issue please let me know and it'll be fixed quickly.


  • Covecube
    Oh, and as far as editing the tags directly using an external tool.

    Don't do it.

    CoveFS caches these tags in memory and it expects the tags to stay in sync with what is on the disk. In addition, it protects the tags from being edited on the pool, so you will not be able to write to them.

    Trying to work around this protection is bound to break something.
  • Member
    Hi Alex, thanks for the precisions.
    Regarding my problems, let me give you my setup:
    * Using Server 2012, all updates, all drivers fine
    * Logged in as Domain Administrator
    * I created a pool from scratch on two empty HDs, freshly formatted
    * I set the permissions on the Pool like this:
      + Replace all child with inherited
      + SYSTEM and domain/Administrators with full control
      + no other rights

    That being done, I created some folders, added additional rights (for Domain/Users), but checked that the SYSTEM and Domain/Administrators are still there.
    Then, with the folders still almost empty, started to setup the duplication counts.
    And the problems start... some folder pass ok, some others fail or are inconsistent.
    Checked for the problematic folders, and they have exactly the same access rights as some that do not fail.


    Regarding the "missing parent tag", if you check my previous 'dir /R' output you will see:
    * Drivers:DuplicationCount.Tag.CoveFs:$DATA
    * but not .:DuplicationCount.Tag.CoveFs:$DATA

    From what I understand, when a folder is duplicated, its parent folder is supposed to have an ADS content "MI".
    In that case, the parent folder does not have any ADS content... certainly what prevents dpcmd to give me the proper count for the folder.
    I copied the ADS of another folder with MI content to the parent folder of Drivers, and it worked again.
    I guaranty you that I did not edit by hand any ADS at all (apart from the previous copy to try a workaround).
    I am just trying to read them in order to figure out what could be problematic.
  • edited May 2013 Member
    Hey there, you owe me one, I finally found where those "access is denied" errors come from.
    Ready, here is the whole story...

    I have setup my pool so that it can be shared over the network, with all of my media files well organized.
    Then I personalized my folders so that they look nice, with fancy icons.

    And all the problem comes from there!
    When you personalize a folder, Windows creates a hidden desktop.ini file in that folder.
    Until there no problem.
    But Windows set as well the attribute R on the folder, to indicate that it must check for a desktop.ini file.
    And here is the problem!
    Apparently, DrivePool is not able to set the ADS correctly for a folder contained into another folder with a R (read only) attribute. Ok, I agree that Windows is a jerk to use this attribute like that.

    Check my commands on how I discovered and worked around that:
    P:\Media\Videos>dpcmd set-duplication Keep 1

    ERROR: Can't set duplication count on the pool. (Access is denied)

    P:\Media\Videos>attrib Keep
    A            P:\Media\Videos\Keep

    P:\Media\Videos>attrib .
    A    R       P:\Media\Videos

    P:\Media\Videos>attrib ..
    A            P:\Media

    P:\Media\Videos>attrib -R P:\Media\Videos

    P:\Media\Videos>dpcmd set-duplication Keep 1

    Duplication count set to 1 on 'Keep'.

    P:\Media\Videos>attrib +R P:\Media\Videos

    You certainly agree with me, this is EXTREMELY CUMBERSOME!
    I really hope that you will integrate that to the next release for dpcmd and the DrivePool Gui.
    (unset the R attribute, change duplication, reset the R attribute)
    Moreover, it seems that the R attribute prevents DrivePool from properly cleaning the directory structure from some drives (members of the pool) when it rebalances or when you decrease the duplication count.

  • edited May 2013 Covecube

    Ok, thanks for figuring that out. That does make sense.

    I will make sure that the duplication tag code works correctly with read-only folders, and that re-balancing and anything else that moves things around deals with this properly.

    The fix will be in the next build.
  • Member
    Great news ;)
  • Resident Guru
    *facepalm* oh Microsoft. From one user to another, thankyou very much paris! :)
Sign In or Register to comment.