Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

Network Shares Dropping in and out?

edited August 2011 in DrivePool
Anyone having issues with M3 where you have it all working then the next time you try a network share the Drivepool shares dont' work, the normal inbuilt ones do but not drivepool, its fixed by restarting the windows services and they come back in 30 seconds or so.

Anyone else?

Comments

  • Maybe, following a totally clean install of WHS 2011 and  Drivepool my next task was to start copying the 6+TB of data back onto my server (was on WHS 1 but moved to temp storage for the rebuild).

    During the long MS copies I occaisonally encounted an 'folder name xxxx no longer available' message, repeated push on the Retry button generally solved the problem with the copy completing succesfully.

    I assuemd the server or LAN was being saturated (only 100Mbps Ethernet) but it maybe more fundamental.

    I will do some more testing and see if I can duplicate the problem although I have finished the mass copy so it maybe hard.

  • Hi

    Yeah i have the same problem my network shares also keep dropping out and its not the server i can connect to the server its just the folder's which you are cant access like you say quick restart of services seems to resovle it mine seems to drop out overnight weather this is because of a long period of inactivity or drivepool running someting during the night i dont know

    Lee

  • edited August 2011 Member
    Yep. I have been having the same issue in the last couple of days.At least once a day im having to restart the drivepool service. :-(
  • this may have fixed itself updating to a newer revision of M3
  • Installed Build 3078, inital testing looks promising..
  • Installed Build 3078, inital testing looks promising..

    Yep. I tend to use the check for updates from within the dashboard. It never found any so i was still running the origal M3. The later build seems to have taken away the last few remaining issues that i had,

    :)
  • Transfer of another 380GB with no errors suggests this later version has resolved the earlier problems.
  • Covecube
    Seems like this is somewhat of a widespread issue that I cannot reproduce. If this is still happening to anyone, let me know.

    In particular, I'm wondering if this has to do with I/O usage from multiple machines.
  • I was experiencing the same problem after update to M3. I managed to diagnose a weak 'when-loaded' -12V rail on my secondary PSU which powers the backplanes. Swapped out PSU and shares are consistently there now.
  • edited August 2011 Member

    I think this is related to server load, more specifically disk I/O.

    As a continuation of my data transfer to the 'greenfield' WHS 2011 I initiated an iTunes library consolidation which would result in all the Music files being copied from the client PC's C: drive back to the WHS. WHS is running build 3210.

    iTunes would copy 10,20, maybe 100 files then error with a typical Apple informative message:-

    'Copying files failed. The required file cannot be found'.

    After further testing i was fairly certain this was not a source file error from the local C: drive but something to do with the target file. I had read that whilst the Drivepool service is running, for example immediately following activating folder duplication on the Music folder it will not service writes to the same folder. I enabled folder duplication and commenced the consolidation again, iTunes consistantly failed with the same error immediately it started copying.

    On examination of my WHS resource monitor the disk I/O is very high which is no surprise as the server is a relativly old system using a Pentium E6600 with a variety of slow disks.

    I would expect performance to suffer during a large copy such as iTunes was initiating but am surprised WHS or Stablebit appears to be unable to manage the caching sufficiently to prevent an application error?

     Update, during the tests the CPU utiliisation on the WHS server averaged 10-50%, Disk queue length on the volumes being written too by Drivepool maxed out at around 5 but averaged < 1. I disabled logging to see if that made any difference but no measurable change occured.

     

    As a final check i changed the iTunes media directory to another client PC on my home network and started the consolidation again, no errors occured between these two peer <> peer connected PC's using a 1Gbps link.

     

  • edited August 2011 Covecube
    @Delboy,

    Was the library consolidation a built-in function of iTunes, or is that something that you were doing? Was this from a OS X or Windows PC?

    Basically, I want to re-create this and try to get the error.

    Edit: Ok, you were probably doing the built-in itunes library consolidation.

Sign In or Register to comment.