Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

Can't access folders after moving them into the pool

edited November 2011 in DrivePool

Same behavior with both my Pictures and Music shared folders.  I can access them fine from the server, but then I move them into the pool (turning on duplication if that matters) and I get access denied.

If I RD to the server I see Pictures and Music folders under both C:\ServerPool\ServerFolders and C:\ServerPool\ServerFolders.Mount (where they are Pictures.2 and Music.2) which I assume is due to the duplication.  The ACL's on the share for the C:\ServerPool\ServerFolders\xxxx folder give Everyone full control and on the file system gives only SYSTEM and Administrators full control.

My other shared folders such as Documents which are outside of the pool are working fine although if I go to D:\ServerFolders and look at the permissions on the Documents folder, I see that the share grants Everyone full permissions and the file system grants the same as above for SYSTEM and Administrators but has r/w (without change permissions and take ownership permissions) for my user accounts.

Why is DrivePool dropping the ACLs when it moves something into the pool?

Comments

  • Hi,

    First of all i dont think anybody will know why some of us have problems with DrivePool and some dont i am lucky and touch wood have only had a few minor problems.

    You could try to remove the drivepool software from your system and do a fresh install i belive there is a tuturial on how to do this,  this has helped many users with DrivePool problems.

    Also you could try to reset the folder permission but as i have found out you will need to reset the server for the permissions to take effect.

     

    As far as i know Alex is working on M4 so there will be no more updates for a while i belive M3 is stable enough to use i have over 12 tb of data on a 24 tb server and all is working fine and stable.

     

     

    Hope it helps

    Lee

  • Have you tried the reset permissions option Alex added after you moved the folder?
  • I had the same problem. On some folder all was fine, but on some folder I got access denied after moving them to the pool. Performing a "reset permissions" as hopster suggests solved the problem for me.

    Go to DrivePool tab in WHS dashboard. In the "shared folder list" select the folder you have problems with. Right-click and select "view folder properties".

    Then on the bottom of the "permissions" tab you check "reset permissions on all sub-folders" and click ok. 
  • Thanks guys, I had not noticed the reset permissions option.  I am giving that a shot for my Pictures folder now where the permissions were reported as being what I expect but were not working.  I have a lot of pictures so it will take a while for this to complete.

    For my Music folder, the permissions just got dropped completely.  After simply adding them back (without needing to reset permissions on the sub folders) everything worked.

    Sounds like these are all known issues so I will just move ahead with the rest of my shared folders.  I was keeping my state in case Alex had needed a live repro of a problem.

Sign In or Register to comment.