Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

Access to destination folder was denied

edited March 2012 in DrivePool
I am having troubles writing to folders. I get the error

Access to destination folder was denied
You need permission to do this action (translated from Danish - sorry)

I have upgrade the last couple of releases, but it has not changed the situation - sure could use the old "reset folder permissions" tool again. 

Any ideas?

BR Steen
«1

Comments

  • Member
    Solution was to get a license :-)
  • why would a license solve the permission issue ?
    i also got permission issues somehow tried the tool but it gives a error.

  • Because an unlicensed version will deny access to the pool. Obviously there is a trial version available.
  • okay thnx,
    well im running the trial version.
    so the issue i got must be something else then.
    thnx
  • I'm having the very same problem. I'm running v1.1.6326 a paid registered copy.  I can only write to one of about 6 folders.

    Very frustrating.

     

    Ron 

  • edited October 2012 Resident Guru
    Hi Ron, have you tried the permissions reset tool [link]?

    If that hasn't worked, can you launch a Command Prompt on the server as the Administrator and try the following command?

    takeown /f p:\* /a /r /d y | findstr /b /v "SUCCESS:" | findstr "."

    (where p: is the pool's drive letter)

    It should (only) report any errors. If you have a big pool, it may take a long time to do anything besides blink the cursor. If it doesn't report any before it finishes, try the utility to reset the permissions again, use the Dashboard to set them to what they should be again, and see if you can then create folders/files. Please let us know how it goes.
  • I tried the executable and that did not work.  I get the following msg:

    Fix was not successfully applied

    Cannot enable take ownership previlidge

    I then entered the line in the command prompt and I got the following msg for each folder that is locked out"

    Info: Access is denied. < "K:\ Music" >

    Info: Access is denied. < "K:\Pictures">

    etc.

     

  • Resident Guru
    Hmm. Try this (read through first):

    Uninstall DP.
    Rename the c:\programdata\stablebitdrivepool folder to stablebitdrivepool.old
    From an administrator command prompt, run the takeown command against the hidden poolpart folder on each of the drives that form your pool and take note of any errors, e.g.

    takeown /f e:\poolpart.{guidstring1}\* /a /r /d y | findstr /b /v "SUCCESS:" | findstr "."
    takeown /f f:\poolpart.{guidstring2}\* /a /r /d y | findstr /b /v "SUCCESS:" | findstr "."
    takeown /f g:\poolpart.{guidstring3}\* /a /r /d y | findstr /b /v "SUCCESS:" | findstr "."

    Reinstall DP.
    Make sure that it is registered.
    Run the "Restore DrivePool Shares" option of the utility.
    Then run the "Reset NTFS Permissions" option of the utility.

    If you get any errors along the way, stop (if it's during the takeown sequence, stop after doing all drives) and post them here. There may be an ownership/security mismatch between the drives that form the pool, or something else might be going on.
  • Appreciate your help Shane.  I won't be able to get at this until tonight.

     

    Cheers

     

    Ron

  • I'm over my head here.

    Drives D, E, F, H, I and L have a unique drivepool string and some are bloody long!

    Example for D: fe0b98eb-ec73-4fff-82e4-3e74bf9bf5b5

    I think I finally entered the line and string properly for drive D and what I got was hundreds of statements such as:

    Info: The system cannot find the path specified. < "d:\poolpart.STRING\software\ebooks\calibre Library\Thomas Paine\Common Sense.................................

    And when it stopped there was no message of success or anything.

    At this point I didn't go onto the next drive.

    Why did this happen overnight??

    A little frustrated at this point.

  • edited October 2012 Resident Guru
    (hopefully I haven't mangled my post on this try)

    The problem we're running into is that the filepaths are longer than can be handled by the Command shell, so we'll have to use Explorer instead.

    For each drive's poolpart folder:
    * right-click it (to bring up its context menu), go to Properties, Security tab, Advanced, Owner, Edit
    * it should look like:
    image
    * choose Administrators, tick Replace, then OK, OK, OK, OK.
    * again bring up its context menu, go to Properties, Security tab, Advanced, this time Change Permissions
    * it should look like:
    image
    or like:
    image
    * remove any non-inherited Permissions (highlight each and click Remove), then tick Include and tick Replace, then OK, Yes, OK, OK.

    If it gives an error message at any point, please post them.
  • Hi Shane,  Your pics got detached from the msg but I don't think that has been a problem.

    I'm working on the 1st drive and since I'm just threading water here I'm following your notes precisely.

    Where you say choose Administrators, I choose Administrators vice Administrator

    After ticking replace and the 1st OK and after a while I got a Windows Security window with the following msg:

    If you have just taken ownership of this object you will need to close and reopen this objects property before you can view or change permissions.

    After a few more OK's I'm at the point of removing any non-inherited permissions. Problem is I'm not sure what those are and Googling hasn't been a help.

     

  • edited October 2012 Resident Guru
    Sounds good so far - that particular message window is normal.

    Inherited permissions: there's a column in the Permissions window titled "Inherited From", which gives the path from which a permission is being inherited. If it's not being inherited, it should say "not inherited".

    The poolpart folders should - at the very least - be inheriting Administrators (Full control) and SYSTEM (Full control) from their drive root. If you can see my pics from the previous message, they show the typical permissions one might expect of a poolpart folder on the WHS data drive (D:) and an added drive (E:).
  • Hey Shane,  This appears to have worked. 

    One thing I noticed that I don't recall seeing before under Server Folders are the following:

    - Folder Namer K which is my drivepool, no description, in location K:

    - Folder name 7485c36205d57f5b91ca1e2d75 which is associated with Drivepool K, description is same as folder name, in locations K:\ 7485c36205d57f5b91ca1e2d75.

    I was tempted to delete them but I thought I'd better ask you first.

    A BIG THANK YOU to you Shane. I do appreciate you taking all this time to help me out with this problem. I certainly could not have done it without your guidance.

  • Any idea why this happened? I'm running DP v1.1.6326.

     

    Cheers

     

    Ron

  • Problem is back.  I cannot write to the same folders as last time.

    I can still write to the 1 folder (same folder as last time)

  • edited October 2012 Resident Guru
    Thanks for your patience, Ron.

    So if I am understanding correctly:

    1. you uninstalled drivepool and renamed the stablebitdrivepool folder?

    2. you were able to take ownership of, and reset the permissions of, all poolpart folders without error message?

    3. you then reinstalled drivepool and ran the "Restore DrivePool Shares" and "Reset NTFS Permissions" options of the utility?

    4. A folder named K, with location K:\, appeared under Server Folders?

    5. A folder named 7485c36205d57f5b91ca1e2d75, with location K:\7485c36205d57f5b91ca1e2d75, appeared under Server Folders?
  • Hi Shane, yes to all except resetting NTFS Permissions. I forgot that step. I am now in the process of doing it all over except now on my 1st poolpart I am getting this msg:

    You do not have permission to read the contents of directory D:\PoolPart.xxxxxxx\ServerFolders. Do you want to replace the directory permissions granting you Full Control?

    All permissions will be replaced if you press Yes.

    What should I do?

     

    Ron

  • For now I answered NO and cancelled out.
  • edited October 2012 Resident Guru
    Hi Ron, answer Yes to that question.

    (sorry for the delay, spend most of today on the road or at job sites - the joys of being a roaming freelance tech; in case you're curious, I'm on Australia's east coast, so timezone is GMT+10)
  • edited October 2012 Member

    Shane you have no reason to apologize, you are doing me a favour and I do appreciate your time. Interesting that you are in Australia. Wonderful country and I would love to visit one day.  BTW, I'm in the Canadian Military presently working in Winnipeg Manitoba Canada.

    While I was waiting for your response, I once again tried resetting permissions using the utility and this time It was successful.

    Everything appears back to normal....for now.  :-)

     

    Ron

  • I just checked and the problem is back.

    Ron

  • edited October 2012 Resident Guru
    ... ooohkay.

    Hmm. Are you running *anything* else on the server besides DrivePool? 

    (and re Canada - speaking of wonderful countries etc, definitely in my Top Five)
  • Good point. Yes, Oracle virtualbox. I have been running it since day one but perhaps a recent update has caused problems? I will shut it down and see.

    Cheers

    Ron

  • Resident Guru
    There have been problems running virtual machines from the pool before, e.g.:

    Though how this would extend to rendering most of your folders non-writable I don't know. If it does turn out to be Virtualbox, the next step - unless you can tweak something in Virtualbox or one of the suggestions in those threads works for you - would be contacting Alex via the Stablebit contact form [link] and referencing this discussion thread.
  • I intend to shut it down tonight to see if that changes anything.  I should have mentioned that I am also running Scanner.  I suppose it's unlikely  that it's the problem.  :-)


    Ron


  • I uninstalled Oracle and went through the entire process but didn't get anywhere. Resetting permissions with the utility did not work.  Within minutes of changing permissions on each folder, they would change back to "No Access"  Been a long day.  I'll try again tomorrow.
  • Resident Guru
    Ugh. At this point rather than try again, I'd contact Alex so he can investigate directly - permissions should not be changing themselves!
  • Thanks for your help Shane.  How do I contact Alex?  I don't see anyway to PM anyone on this forum unless I'm missing something.

    Cheers

    Ron

  • To contact Alex use this form: http://stablebit.com/contact
Sign In or Register to comment.