Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

DP 1.3.7388 99.9% pool condition

edited February 2013 in DrivePool
I've always had 100% pool condition, but now it has fallen to 99.9% for some reason. I've done a reboot, remeasure and "check duplication consistency, but it's still stuck at 99.9%. I guess a very small number of files (perhaps only one) is not duplicated for some reason. Is there any way to get DP to list out any duplication issues?

Comments

  • Ok.. I am seeing this as well 99.9% but I have 1.2.4.7226.. 
  • I never found out why, and I'm still at 99.9%. I annoys me that I cannot figure out what/which files are not being duplicated properly. 
  • Maybe Shane or Alex will chime in on next steps on how to zero down the issue.
  • edited February 2013 Resident Guru
    If a pool fails its duplication consistency check, the pool's condition is rated at 50% regardless of how many or few files failed, and the user will be notified if DrivePool is unable to fix the problem - see http://forum.covecube.com/discussion/comment/3633#Comment_3633 for Alex's explanation of this.

    So 99.9% with no warning is (I presume) likely to be a balancing problem (and I would be annoyed too if I couldn't figure out why). You could try checking C:\ProgramData\StableBit DrivePool\Service\Logs to see if that reveals anything?
  • I have checked the logs and there is nothing there. I've done a rebalance and a "check duplication consistence" neither returns any errors. Not in the UI and not in the logs. And still pool is at 99.9%. Perhaps it's a rounding error :)
  • Me too.. nothing in the logs... and no errors when running "check duplication consistency"
  • edited February 2013 Member
    Same here. 99.9% and no evident errors.

  • were at 3 and counting :)
  • Resident Guru
    Does a Remeasure have any effect?
  • Not for me. Neither remeasure or check duplication consitency does help.
  • Same here no effect for either
  • edited February 2013 Resident Guru
    Aha. Knew I'd seen the answer somewhere. From the horse's mouth (or in this case, http://blog.covecube.com/2012/08/stablebit-drivepool-1-2-beta/):

    "Sometimes, if you lack any small files on the pool DrivePool will not be able to satisfy the balancing model entirely, or “fill in the gaps” so to speak, but it will come as close as possible given the available files. As you can see in the screen above, it re-balanced to 99.9% accuracy."

    Basically, if you've got 10 files of 10 MB each and 9 drives - or any other similar ratio - it's simply impossible to evenly distribute the content amongst the drives. DrivePool just does the best it can.

    (I do think the UI should be tweaked to make it clear that this is not actually an error in or failure of the pool)
  • Hm. 

    I've got 6 HDDs in my pool ranging from 500GB to 2TB in size. Lots of free space on all disks so balancing should not be a problem.

    But I did a "reset everything to defaults" under the balancing settings in DP and suddenly the pool condition jumped to 100%. I'm pretty sure I already was running with defaults (at least I have not intentionally changed anything there).

    Perhaps one of the (beta) upgrades have had some settings changed that got reset now. Anyhow I'm a happy camper again.
Sign In or Register to comment.