Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

Performance issues streaming medium to high bitrate files

edited February 2013 in DrivePool
I am running Drivepool 1.2.7226 with Stablebit Scanner 2.3.2859 on top of WHS 2011.  I am running on a Supermicro X9SCM-F motherboard with an I3-2500T processor with 4 GB of RAM.  My system drive is an OCZ Vector 2, and my pool drives are all WD drives, mostly 2 TB green drives, with 1 2 TB Black, and 2 3 TB RED drives.  I'm having an issue streaming a relatively high bitrate MP4 file to my WDTV live plus player.  The bitrate is about 2 MB/s.  When I was on WHSv1, it streamed without any issues whatsoever using the same hardware.  The interesting thing is that I have much higher throughput now than I ever had on v1 when copying files, but I cannot play any medium to high bitrate streams without encountering stuttering.  My movies are all duplicated and I have tried enabling and disabling read striping.  I know green drives aren't the best for streaming, however this particular file is on the 2 TB black drive, so that shouldn't be an issue.  I have one Dell Gigabit managed switch between the server and the WDTV live +.  It has been rebooted, and the WDTV live has been hardware reset.  It will play the file just fine via USB.  I'm pulling out my hair and my wife is less than pleased as we watch these home videos frequently.

I have AirServer running that I didn't have on V1, but I have tried disabling it without any success.  I do not have media services running, and when monitoring the server, there is absolutely no load on it.  Low bitrate files play just fine. 

All of my drives have been scanned and check out healthy according to Stablebit.  I have temporarily disabled any power management so the drives do not go to sleep as that was causing quite a few issues as well. 

My drives are about 87% full.  I am running the disk space equalizer, but have it set to only run every 72 hours, and I know it's not running when I was trying to stream.  I have run a manual defrag on the drives just to make sure there wasn't an issue.

I did a manual migration of files from WHSv1 to WHS2011.  I was using the advanced format jumper on V1 and instead of migrating them with that, I moved the drives one at a time and reformatted and moved the data by hand.  Everything else is running great except for this.

Any ideas?

Comments

  • Resident Guru
    Presuming that you've checked that the MP4 is streaming via DP from the 2TB Black and not from its duplicate on one of the other drives, then to test DrivePool's involvement I would:

    1) Stop the DP service.

    2) Explore the 2TB Black and move (not copy) the MP4 from the hidden poolpart folder to a non-poolpart folder on the same drive.

    3) Copy (not move) the MP4 back to its original poolpart folder location on the same drive.

    The above order of moving and copying should ensure that you aren't changing the original file's physical location on the disk (in case that's a factor).

    4) Start the DP service.

    5) Stream the MP4 from its new non-pool folder using the same method you used when it was in a pool folder (so you may need to set up a share for that non-pool folder).

    In theory, if the stuttering remains you've ruled out DrivePool and if it goes away DrivePool is (at least part of) the problem.

    If that don't work: you mention a manual defrag of the drive (darn it, that was my next guess); have you checked that this particular file was actually defragged (some defrag apps allow you to work on individual files)?

    You could also try moving the file to other drives, see if any/some don't stutter (or stutter worse). And try moving the drives between controllers, if you have more than one, to rule the latter out (or in).
Sign In or Register to comment.