Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

Balancing question on Drive Pool v 2.0.0.202 BETA

edited February 2013 in DrivePool
Hi guys, drive pool has been running great but I noticed something interesting today. Here is my current setup.

HP EX495
80gb Intel X25-g2 SSD (OS Drive)
2 x WD Red 2TB Drives
1 x Seagate 500GB Drive
Stablebit Scanner v2.3.1.2860
Stablebit Drive Pool v2.0.0.202 BETA

The three mechanical drives are part of the pool labeled drive F: I've turned on duplication for a few folders, not the entire pool.

The two WD Red drives have data in the pool folder, the Seagate HDD is completely empty. It seems like drivepool is not utilizing any of that drive at all. Scanner is not reporting any issues at all.

Folder duplication is turned on using the dpcmd on the following folders.

f:\serverfolders\client computer backups\ expected number of copies: 2 found number of copies: 2
f:\serverfolders\west coast auto group\ expected number of copies: 2 found number of copies: 2
f:\serverfolders\users\ expected number of copies: 2 found number of copies: 2
f:\serverfolders\videos expected number of copies: 2 found number of copies: 2

The two WD Red Drives have the following drive letters assigned.

D: and E:

The Seagate drive has the following drive letter assigned.

W:

Before I turned folder duplication on the Client Computer Backup folder, I noticed it was already on 2 hard drives but without overlapping files, since I turned folder duplication on, it has started duplicating perfectly. I've changed the balancing schedule to 5am as not to overlap with my backup schedule.

The Seagate Drive has a poolpart folder that's empty.

Any reason why I can't get it to use that drive at all?

Comments

  • edited March 2013 Resident Guru
    I'd suspect it has something to do with the balancing algorithm's tendency to pick whatever drive has the most free space when first writing any given file to the pool.

    There are default limits (that you can manually adjust from the Balancing menu in DP 1.2+, not yet available in DP 2.0 beta) that will trigger an automatic rebalance to spread the pool evenly across all drives, it may just be that your particular arrangement of drives and files - e.g. two drives much bigger than the third - hasn't hit those limits?
  • edited March 2013 Resident Guru
    My bad. Balancing menu is indeed available from at least DP 2.0.0.202 beta onwards; click the upright triangle adjacent to the pie chart for your pool and choose Balancing....
Sign In or Register to comment.