Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

Folder duplication not working on beta 2.0.202

edited March 2013 in DrivePool
I have used dpcmd to set duplication on some folders in the pool to 2 (and the command seems to work, querying the value I set returns the correct count). This is with a 2 disk pool. I assume 2 means to have two copies, not 2 duplicates i.e. 3 copies in total.

But nothing happens. The GUI doesn't show anything, and I can't find any settings that will start or schedule the process. Reading posts on here makes it sound like the GUI will immediately show the duplication process starting, but this doesn't happen for me.

This is running on Windows 8 Pro, x64.

Comments

  • edited March 2013 Resident Guru
    It appears that the dpcmd duplication is not (yet?) tied to the GUI. If you enable duplication via the GUI itself, you get a little "x2" symbol next to the pie chart.

    And yes, a value of 2 means 2 instances of a file.
  • Ok thanks. But I am still struggling to have fine-grained control over folder duplication.

    I read that enabling duplication via the GUI duplicates everything twice, which is not what I wanted, so I didn't enable it. I set the duplication counters using dpcmd, but no duplication took place at all, almost as if the service wasn't running.

    Since enabling duplication on the GUI, now everything is duplicated.

    To have fine grained control, is the only way to enable duplication via the GUI and then reduce the duplication setting on specific folders using dpcmd?

    Otherwise I can't see how this is working properly. On my installation, setting dpcmd on it's own does nothing.
  • Resident Guru
    I've now done a little experimenting with this (on Win 7 x64); yes, there does seem to be a disconnect between changes being made via dpcmd and the pool updating to reflect those changes. It knows that it should have more (or less) instances, but it's not actually doing anything about it. At one point it noticed and the pool bar went from green to yellow, offering a consistency check which worked, but that only worked the once. I'm going to leave the machine on overnight to see if the nightly check is also affected, then submit a bug report.
  • Glad you could reproduce it.

    The advice that the GUI does "all or nothing" is correct then, but that advice that you can manually set duplication count via dpcmd doesn't seem right at the moment.

    I really hope you can fix this and the problem viewing long directories over SMB on Mac/Linux clients, before my trial period runs out, only about 20 days left! Really want to use DrivePool but those two issues are too serious for me.
  • edited March 2013 Resident Guru
    Hi, I didn't get to submit that bug report (note I'm not a Stablebit employee, I'm a fellow user), but just to let you know per Covecube's latest tweet, 2.0.0.220 BETA is now out - per-folder duplication has been integrated into the updated GUI and partial directory listings for non-Windows clients has been fixed. Please check it out. :)

  • Tested the update and it's working perfectly!

    Cheers
Sign In or Register to comment.