Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

Metabrowser problems

edited July 2011 in DrivePool
Hi, I've been using DrivePool (M2/1925) for a while now without any problems, I only pool my movie folders.

I am having a problem with Metabrowser 1 (09.02.09) with it not detecting any new movies added to the pool. It worked perfectly on WHS v1.

Also when I manually run Metabrowser and add xml and images they do not always show in the movie folder they were added to even though they are there. If I look in the pooled folder from the server I can see them but they do not always show across the network - this is not so much of a problem because MediaBrowser does detect them, Just a bit odd. Possibly a problem my end with my PC not refreshing the folder properly?

It's the Metabrowser issue I would really like to sort as currently it means I have to remote to the server and run it every time I add movies, which is a pain!

Any ideas would be greatly appreciated.
Cheers,
Steve

Comments

  • Covecube
    I will look into this tomorrow.
  • Covecube
    Steve,

    I've installed the same version of metabrowser on my WHS 2011 test machine and I can't get it to detect changes even on a non-pooled folder, can you confirm this?

    It seems to only pick up deletes and not new files.

    As for the other problem of missing files, what OS is the client PC running, Windows 7?
  • I'm running v9.02.09 of metabrowser on my desktop, pointing to my WHS2011 box running the last M2 of DrivePool, and I don't have any problems with metabrowser updating.

    Now, I don't run metabrowser on the whs2011 box, I run it on a desktop and point to whs2011, not sure if that's the difference.

  • Covecube
    @Prelector What OS are you running it on?
  • edited July 2011 Member
    Thanks for the reply guys. Alex, in the options for MB i just enable the folder monitoring options and set to start at system startup. I did wonder if MB wasn't starting so I connected the server to my monitor and set auto admin login and set MB to login from that account as well, but even if I RDP to the server and make 100% sure MB is running it still does not detect anything added.

    Now what I haven't tried is a simple test of it detecting on a non pooled folder - I really should have tried this!

    Prelector, I haven't tried it this way because it really defeats the object for me because I have 4 PC's in the house and movies can be added from any of them. If this were not the case I could just run MB on this PC and tag them before I added them to the server.

    I shall try tagging from a non pooled folder....
  • I'm running MB on a Win7Pro desktop.  It points across the net to my shared whs2011 folder.   Also, I don't run it constantly; I run MB when I need to add new movies, then shut it back down again.  It DOES see the new movie folders though, once it's started up.

     

    Steve, does it pick up the new movie folders if you manually hit the Start Refresh button, on the lower left corner?

  • Member
    Prelector yes it does see the movie on a manual refresh and I have just tested adding a movie to a non pooled folder and MB does see it and auto add metadata. So it must be to do with DrivePool.
  • Interesting...  It sounds like a problem with the local run application seeing the shared folders...

    Do you point metabrowser to the local c:\serverpool\serverfolders\<share folder> or to the unc share \\\<server>\<share folder>?

    Whichever you're currently using, you might want to add the alternate path (you can have multiple paths configured) and see if that corrects the problem.

  • Member
    Yeah I point to c:\serverpool\serverfolders\<share folder>

    I'll give it a try the other way. Thanks for the suggestion.
  • Member
    No that doesn't work either. :( 
  • Covecube
    Steve, try it with a non-pooled folder and see if it works differently. I couldn't get it to work.
  • Member
    Hi Alex. As mentioned above replying to Prelector I did try it with a non pooled folder and it works fine.
  • Covecube
    Sorry, didn't see that
  • Member
    It's got me stumped really. If it can see the movie after a manual refresh what could stop it seeing it when added? What makes it so different to another shared folder as far as MB is concerned?
  • Covecube
    The only thing I can think of is that it doesn't like DrivePool's file change notification... But I noticed that it has a timer based refresh option, so it's strange that it doesn't work.
  • Maybe try pointing to the c:\serverpool\serverfolders.mount\<share folder>?  Alex mentioned that the .mount is the point we should be pointing to now...  Only thing I can think of.
  • Member
    I am using C:\ServerPool\ServerFolders\MOVIES.1 not the unc share.
    That is correct isn't it?

  • Member
    I'd say it's not correct, Prelector and Alex said to include '.mount' and Prelector suggested adding both the paths (c:\.... etc and the unc path) I have no knowledge about metabrowser however, just reading the thread ;)

    Cheers,

    Danee
  • Yea, you should see TWO directories now, under c:\serverpool:

    c:\serverpool\serverfolders (this is the old directory that shares were created under)

    c:\serverpool\serverfolders.mount (my understanding is this is a new directory that will be used going forward)

    Since pointing to the UNC share didn't work, and pointing to c:\serverpool\serverfolders\<share> didn't work, let's try the final option:  point to c:\serverpool\serverfolders.mount\<share>

    Now, I don't think this will work any better... but we should try every option open to us.

  • Member
    Oh right. I didn't know this because I don't have a folder with .mount in c:\serverpool. Only the one I previously stated. I take it there should be two folders then?
  • DOH, didn't notice that you were still on M2.  The additional .mount folder is created as part of the M3 build.
  • Member
    Well thanks for inadvertently letting me know there was a new build :) will give that a go.
  • Member
    No joy with M3 build and pointing to C:\ServerPool\ServerFolders.Mount\MOVIES.1 :(
  • Covecube
    I've added this to the list of issues because there's a support case with another app that's experiencing the same symptoms. DrivePool's file notifications might need to get sorted out.
  • Member
    Ok. I suppose it's good to know it's not just me!?

    Thanks for everyone's help and good luck finding a fix.

    Steve
Sign In or Register to comment.