Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Poll

No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.


The new forum is at: http://community.covecube.com


The new forum is running IP.Board and will be our primary forum from now on.


This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.


Thank you,

DrivePool BETA M4 - Migration test

2

Comments

  • Covecube
    Just an update.

    The link was disabled because of a rename bug. This is not migration related.

    I've fixed a number of issues in the latest build. Some were causing blue screens, and the rename bug.

    It's being tested now, once it passes I will put it up.
  • Covecube
    ...
    Can it be possible M4 cause damage to harddrives?
    DrivePool cannot physically damage hard drives.

    It doesn't access drives directly, it accesses the files on the drives using file paths, just like other applications.
  • edited January 2012 Member
    Have now updated from M3 to M4 no issues or worries so far, and it's not causing the issues that M3 was for me in crashing different services etc.

    2.87 TB (or data)
    5 Discs
    10 Shares
    336,000 Files
    37,000 Folders

    Migrate: 3mins
    Measuring: 2hrs
    Duplicating: 1hr
    Indexing: 15hrs and still going

    I love the fact that the pool is now a drive, it always annoyed me a bit it being a few sub-folders in on C: (and it looks much much nicer to have the pool looking like a plan old HDD).  So the migration went fine, all shares appeared as they should and are available without issue...

    Have been having issues with backups (before M4), not sure what was the cause of that, but once the newer M4 comes along I'll be trying to sort that out...

    Thanks for all the hard work Alex, I am again very happy and feeling WHS2011 is now what it should have been!

    ETA: Oh and a quick question for everyone:
    Is anyone using 3TB drives (either now with M4 or previously with M3)?

    I've got a 3TB drive that I added to my WHS just before I upgraded from v1 to 2011.  v1 did not like the drive at all, even not in the pool it didn't like it...2011 picks it up as it should (2.73TB) but I haven't been game to add it to the pool so far, but I'm thinking I will now that it's been playing nicely and I don't see why Dp would have a problem with it.  Thoughts?
  • Note: I'm running Storage Server.
    2x 3TB drives here, no problems to report although these drives were migrated into the M4 pool rather than added as new drives.
  • edited January 2012 Covecube
    Download is back with build 5387. Look at the top of this thread.

    How to upgrade M4 to M4?

    • Install the new build.
    • Reboot the server.

    I will update the wiki tomorrow and post a full change log. Fixed some crashes and the rename bug.

    There is a long thread on this forum regarding boxee issues. I will look into this soon.
  • Download is back with build 5387. Look at the top of this thread.
    How to upgrade M4 to M4?
    Install the new build.Reboot the server.
    I will update the wiki tomorrow and post a full change log. Fixed some crashes and the rename bug.
    There is a long thread on this forum regarding boxee issues. I will look into this soon.
    Thanks for the update.  Just finished installing it and rebooted.  Was upgrading from the initial M4 release.  The dashboard still says indexing, but I did a scan using SmartSync Pro 3 and it verified that all the data on the drives correctly matched the master copies I have been keeping while trying out the betas, so everything looks good for me.  Still have this random 689 bytes of unduplicated data that I can't find, but hopefully I will eventually track it down.  Thanks for your hard work, this product is awesome!
  • Uhg, my M3 got unhealthy/un-duplicated files again today, it's been chugging away for hours again with the repair.

    Is it possible to upgrade from M3 to M4 with unhealthy drives? 
    (or would it be faster to change shares from duplicated to not duplicated temporarily?)

    I'm really excited to get my M4 going on with indexing, but I'm still stuck with unhealthy M3 drives. :(
  • I'm getting the following error when upgrading from the latest M3 to M4.

    The add-in cannot be upgraded.

    I have tried removing the M3 and reinstalling M4, but no drives were listed as available. I then removed M4 and reinstalled M3 and attempted the upgrade again, but encountered the same error :-(
  • Hmm...the new M4 is causing the same issues as M3 was in the end for me... (account logging out (I'm guessing from the different services crashing), dashboard doesn't want to start at all), when I first installed it it said a drive that I had removed before I installed it was "removing" so maybe that is the root of the issue.  Have uninstalled the second M4 and will reinstall the first M4 and see what it says...

    Alex one small note if it's of any concern, since dashboard wouldn't start I went to programs and features to uninstall it and the version was showing as 1.0.5387 ie missing one .0, not sure if that matters to you or not...
  • Success, I'm now on M4 and old M3 shares migrated successfully.   Indexing is happening, and I'm able to add library's into my Win 7 laptop at last.

    I had one unexpected server reboot, and submitted a ticket with full logs.  I'll leave that to Alex in the one on one support ticket.      Things have been fine after the one reboot so far.  I'll let things fly over night and see how it goes from there.
  • edited January 2012 Member
    I just made the migration from M3 to M4 with the lastest build. It went like a charm. As the pool is now seen  as a disk, I wanted to give it a name. This does not seem to work. Is it normal ?
  • I also have not been able to label the pool drive - would be nice if it would have a label by default (DrivePool) to make it stand out.  I also manually moved the drive letter to keep it away from hard drive additions/subtractions - Alex, you might think about using the last available drive letter by default instead of the first...  also could it be user select-able (advanced install option?) during setup?  or an option somewhere to change it?  The manual method works, but...
  • I upgraded from M3 to the build of M4 built today, everything seems to work fine except the only folder that got moved to the D: drive was the "Client Computer Backups" share. All the other shares are still pointing to C:\ServerPool\ServerFolders\xxx and if I browse to that folder, it's still clearly a junction point to the old M3 style folder:

    C:\ServerPool\ServerFolders\Movies --> \??\C:\ServerPool\ServerFolders.Mount\Movies.1

    Should I reboot?
  • edited January 2012 Member

    Hi,

     

    Just installed the new M4 i only had 1 problem and that was with the client backups but i think i have that sorted now otherwise all is running 99% ok tho there are only 2 things i see as misssing parts

    1. The new Drive can not be renamed

    2. The pool tab no longer shows the names of the Drives installed on the server this was very useful if there was a problem with a drive you knew which 1 it was and could remove it Alex could you please add this back on

     

    Great work Alex

     

    Lee

  • I upgraded from M3 to the build of M4 built today, everything seems to work fine except the only folder that got moved to the D: drive was the "Client Computer Backups" share. All the other shares are still pointing to C:\ServerPool\ServerFolders\xxx and if I browse to that folder, it's still clearly a junction point to the old M3 style folder:

    C:\ServerPool\ServerFolders\Movies --> \??\C:\ServerPool\ServerFolders.Mount\Movies.1

    Should I reboot?
    Philmatic - I had this same issue initially. Here's what Alex had me do (and it works):

    You can simply right click on the folders in the pool root, go to properties and share them.

    image

    Click Advanced Sharing -> Click "Share this folder".

    Before clicking ok, click "Permissions" and make sure allow "Full Control" is checked.

    You should do this for each folder that was not correctly re-shared.
  • Seem to be haveing problems with the client backups all was fine on M3 now none of my computers will backup if the client backup folder is on the pool plus for some odd reason the folder gets this added to it when i move it or recreate it to the pool

     

    Client Computer Backups.DELETE.{F3D68A23-FA5D-4A66-95B8-85AF7868CE70}

    the folder is locked when on the pool preventing any changes to it

     

    Lee

  • Playing a bit more with M4, I got the following when moving a folder: The folder was moved successfully with some errors / Cannot enable shadow copy on the hard drive.

    Then when I re-move the folder from the pool to another disk, there is no problem at all. This happens only when I move a folder to the pool. (tried a lot of times)

    When I look at the drive representing the pool, I see the folder existing at time of M3 (I had only one very large folder in the pool) and a folder named "ServerFolders" containing the new moved folder and all other folders I could move.

    Why this difference between a pre-M4 pooled folder and M4 pooled folder ?

    Moreover, I noticed a temporary strange behavior. The pre-M4 folder was not referenced as pooled for a moment. After some closing and restarting of the dashboard and changing the views between "Integrated user interface" where the pre-M4 folder was marked Pooled and the other view where it was not included in the pooled folders, eveything was OK. Does this mean something?




  • I just sent in the following support ticket, but wanted to share here with everyone as well.

    _________________________

    two problems (and 3rd question)
    1) Can't repair Client Backups, or backup computer any more.

    Errors exist in Client Computer Backup

    Computers and Backups (JazPad is critical)

    Additonal client computer backups tasks

    Tools, Repair now,

    Repair the Backup Database
    The wizard did not complete successfully
    Backup repair did not succeed
    The wizard cannot repair the errors in your computer backups

    Can you help me delete/reset the backup for JazPad?  I want to have you double check things got migrated and or are in the correct location.


    2) Even though new default shares are in libraries on media center, I see no shares via media center extenders (xbox 360)

    Can you help me figure out how to force WHS Media Player library/database/index to reset itself again?   You helped me fix this awhile back but maybe we can get it right now in M4

    3) Can I safely rename the default pool drive letter from M: to P: ?
  • @ jazon

    if you move the client backup folder off the pool it works fine and you can repair it without problems seems the pool does like the client backup folder  and it was fine on M3 easy fix for alex one thing i did notice was the backup gets to around 30% for me then a get and interuption error what ever that means hope that helps.

     


    Lee

  • I'm also having a problem with client backups...
  • Just installed M4 and all went fine. I only have 2 drives in the pool for testing purposes and 5 out. Migration went well, took about 3-4 minutes to complete all tasks. Really like the integration with WHS2011. It makes sense to me. One thing I noticed after is the increase speed in copying files to the pool. With M3 copying files to drives out of the pool reached 40-50 Mb/s, while in the pool I got 13-15 Mb/s. Now both are equal speed 40-50 Mb/s, which is really good. 1.5Gb file copied in less than 60 seconds.

    I'm wondering why people would want to keep their backups in the pool. New feature with WHS 2011 is the ability to backup the server and the clients backups as well. If the system disk crashes, just use the server backup and you are up and running in minutes. My system drive is 1 To and I have 800Gb of space available for the clients backup which is more than enough. I have 4 desktops and 2 laptops to backup. The way clients backups are handle is working well for me. I prefer to use all the space on the pool for my data and duplication. Just my 2 cents on this...

    Thanks for the good work Alex!

    Claude

  • I started having issues I noticed a few days ago with my client backups using M3. I backup those with crashplan and tried deleting and restoring the client backup files on the pool. When I restore it still won;t repair or open the database. I converted this evening to M4. After trying the restore twice from crashplan I was setting it up to backup the clients from the start tonight. Maybe I try the restore once more?
  • I just got a good response from Alex, wanted to share the fix in case in helps anyone else that didnt submit a support ticket.

    Jon,
    For #1  (Client Backup errors)
    • Stop the Windows Server Client Computer Backup Service.
    • Delete everything in Client Computer Backups.
    • Restart the service.
    • For each computer, click Set up Backup for this computer.
    For #2 (Can't see Photo/Videos via Xbox 360 in Media Center Extender mode)
    • DrivePool M4 doesn't do anything special with media streaming, it's all WHS from now on.
    • You should use the Wss Troubleshooter at the bottom of this page:
      http://wiki.covecube.com/StableBit_DrivePool 

      I created this tool based on my experience with fixing your media streaming index before. It will do the same thing and reset everything.

      It works with M4.

      Don't forget to run it from C:\Program Files\Windows Server\Bin
    For #3 (renaming the DrivePool letter)
    • Hmm... I've never tried it. Let me know if it works. It should be ok.
  • edited January 2012 Member
    The Media Streaming is still wonky unfortunately.   When I pull up Videos or Pictures from my XBOX 360, no folder is listed.   It's blank in both Media Center Extender mode and the Xbox Dashboard Video page.  (See's the drive letter, but nothing below that)   I rand the fix awhile ago, maybe I'll try it again and wait over night.

    Another response response about my unexpected server reboot.  I sent the dump file and Alex identified the problem and said has already fixed it!  He's on fire as usual.    

    The basics are working well, but I'd really like to get my XBOX 360 working in the bedroom.  It never really worked well on M3.    It was fine on the old WHS V1 though.    Anyone else have an Xbox 360?     (and or Windows 7 machine you can setup some Videos/Pictures libraries pointing to the DrivePool server?
  • @ jaz

    I'll set it all up tonight and try it for you I need to know what format your media is in all mine is either m2ts or Iso which Xbox/ps3 can't run so I never botherd setting it it.

    Lee
  • edited January 2012 Member
    @lee1978 Thanks!   My videos are all .AVI files  (DivX/XviD)   

    I got a bit further, when I tried to remove edit my library inside media center extender(xbox 360) it usaully hung and I gave up. This time I let it sit a long time and it actually removed the old \\MEDIA\Pictures
    (MEDIA is my WHS 2011 box)


    I then went to ADD a folder in pictures, choose "from another computer" picked MEDIA, Pictures and............

    "CANNOT ACCESS FOLDERYou don't currently have permission to access this folder.  To add it to your media library, go to your PC, open Windows Explorer, and verify that you can access the folder"

    http://i.imgur.com/k8mTw.jpg


    Ok so I went to my HTPC (Media Center) computer in the livingroom.   For some reason the Pictures library was empty!  (I added it last night)    I went to re-add \\MEDIA\Pictures to Pictures I got a popup message that says 

    "File SharingWindows removed the locations from your library, but couln't stop sharing one or more locatoinsMore information (hyperlink"    (Windows can't change this folder's sharing settings because it's on another computer)

    Well it still works in my library after that, but something is wrong still.

    Ok well like I said the library's now all show up on my HTPC machine so it was time to go try Xbox 360 media center extender again.

    on Xbox 360 I goto add the pictures folder to the library once again, and the same error pops up.http://i.imgur.com/k8mTw.jpg

    I go to check my HTPC and low and behold, the Pictures library is not linked to anything again."Pictures is empty, No folders have been included in this libraryInclude a folder (button)"

    I'm stuck in endless loop of library weirdness.  I don't think it has to do with the streaming thing maybe hmmm.

    I can view all videos and pictures on my Windows 7 HTPC Media Center,  the xbox 360 has never been happy with DrivePool though. 

    I let Alex know all the above so hopefully he can help me figure it out since not too many people have both DrivePool AND xbox 360's as extenders
  • M3-M4 10TB Of Data, migrated seamlessly & cloudberry backup now working perfectly also!

    Many Thanks
  • edited January 2012 Member
    For #1  (Client Backup errors)
    Stop the Windows Server Client Computer Backup Service.Delete everything in Client Computer Backups.Restart the service.For each computer, click Set up Backup for this computer.
    Must I delete all my backups? That really annoys me!
  • edited January 2012 Member

    @jaz

    Tryed the xbox360 was working fine this is what i did

    1. Turn on the xbox

    2. Go to server click on start then click computer click Network  right click xbox360 make sure streaming is switched on right click streaming options make sure ther server is allowed

     

    3. Goto dashboard server settings click media make sure media server is on click customize make sure you have some shared libray's click ok

    4. go back to xbox manually goto the video folders select your server all the films pop up click play at thats it.

    5. i did notice tho the playback quality of the xbox is very poor i recomend a stand alone meda playback streamer then you will get full HD playback

     

    on a 2nd note i cant get the client backups folder to work within the pool if anybody has this going let me know how i tryed the above steps but still nothing i get to 30% and get a service interuption fail

    move it of the pool all is fine

     

    Lee

    p.s whs does not support media center so you have to navigate to the folders direct on the xbox press the middle button /media thats how i did it worked fine

     

  • Covecube
    As for the backup issues, the instruction above are on how to delete the backups. I try to avoid doing that, because obviously they will be gone.

    I'll be testing backups more concretely but so far, everything is working as expected over here.
Sign In or Register to comment.