Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Our Sites 


No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.

The new forum is at:

The new forum is running IP.Board and will be our primary forum from now on.

This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.

Thank you,

Windows Server Essentials 2012

edited January 2013 in DrivePool

Is this planned to be supported on WSE any time soon? I really don't like the lack of features of storage spaces and miss DrivePool :(


Also, will my license be transferable if it is supported in the future??





  • 2.0 beta is out with ws2012e support now.
  • "@covecube: DrivePool BETA: (Supports Windows Vista and newer)"
  • Just had a quick play on my test box. Nice simple app but with limited options as its an early beta. You can either set the whole pool duplicated or not and you cant move shares onto the pool yet as it moans about the covefs file system of the pool. Had a quick look for the advanced options config to change the pool from covefs to ntfs but its not in the beta yet (or I missed it . :-?
  • I'm having the same problem hopester.  I'm not sure this is ready for 2012 essentials yet.
  • edited February 2013 Covecube
    Server 2012 Essentials is not one of the 10 supported operating systems (yet).

    Windows Server 2012 should work fine. I'll look into 2012 Essentials compatibility at my earliest convenience.
  • Thanks for the update, I'll hold up testing until I read 2012 is "mostly" working..  I think most die hard server guys on here are all about 2012 :)   I'm pretty stable on 2011 so I guess I should resist diving in, but knowing me I will the first sign it's working for someone else.  :-D
  • edited February 2013 Covecube
    DrivePool 2.0 now supports Server 2012 Essentials (starting with build 160).

    I've even managed to sneak in some (very) minimal Dashboard integration. You can manage your pool from the Server Folders tab.

    I'll try to get the new build out by the end of the day.
  • Wow awesome thanks for the extra effort Alex. You are amazing as usual. Fun times ahead soon it seems. 2012 here we come!
  • Covecube
    Alright, I've put it up.

    It's not going out as an auto update because there are literally no other changes except some tweaks to the file system for the Server 2012 Essentials and the Dashboard code.
  • Wow, great news on 2012 Essentials!  Thanks for the quick work.  Much appreciated!!!
  • Alex, I installed the new beta and I'm transferring my client backup folders over to the drivepool as I'm typing this.
  • Let us know how it works Chuck.  I'll blow away my 2011 and put on 2012 if it's working for you. I'm ready to help beta test.  Hopefully my external USB 3.0 2011 drive pool drives are picked up/imported smoothly once I re-install 2.0 on the new 2012 OS.
  • So far no problems.  I moved my client backups folder over with no issues.  My backups are scheduled for later tonight and if they work fine I'll post back tomorrow.
  • Were  you using 2011 before?  I want to hear that my current 2011 pool "should" be picked up by the new DrivePool install once I get 2012 on.
  • edited February 2013 Member
    Sorry wrong thread.
  • Covecube
    One thing that you'll have to deal with if you're going from DrivePool on WHS 2011 to 2012 Essentials is folder shares. Just like on WHS 2011, the data will be there but none of it will be shared so it won't show up in the Dashboard.

    I just did a quick test of the WSS troubleshooter's folder re-share feature and it works correctly with DrivePool 2.0 and Server 2012 Essentials.

    So in theory, just plug in your old pooled drives and do the re-share from the WSS Troubleshooter and the Dashboard should pick up all of your old data.

    Oh, and build 165 of the WSS Troubleshooter is multi-pool aware, so it should even re-share folders on multiple pools.
  • Excellent!  I'm ready to dive in this week then.
  • Did I say "this week"? I meant tonight of course! (couldn't wait)
    So I actually remembered to deactivate my Scanner license this time finally before blowing away C:

    I love how 2012 doesn't have that stupid minimum hard drive requirement that 2011 had.  I have a 80 gig SSD drive and had to create a special install ini to force it past.  2012 can be installed on as little as 32GB C: so I'm good to go!

    So I took notes of the little utlils and app settings of my 2011 environment.
    I made sure my pool was duplicated and stable
    I made sure I backed up the MyMovies database
    I made sure I had the WSS Troubleshooter file handy

    I created a 2012 bootable USB drive via MS USB bootdisk maker:


    I forgot that I have to pick a internal domain name now.  Not a big deal, I plan on using basic local accounts since I like Live ID login on my Windows 8 machines.  (simply use Credential Manager to save/remember it one time, first time connecting to shares)

    I created the same local account names I used on 2011.

    installed and re-activated DrivePool

    I ran the WSS Troubleshooter and restored all my shares.

    I fixed the permissions in dashboard users.

    Ok, this is strange, I'm not sure it's related to DrivePool, but my server wasn't showing up under Network Computers when viewed in File Explorer.  (from my laptop OR even on the server directly!!!)

    I googled up the problem the first fix I tried actually kind of worked!  Anyone else come across this problem?
    "Computer Browser" services on MEDIA was disabled. Set it to Automatic. - MEDIA is now showing up in the Network view and Net View list.

    I can finally see MEDIA while on the MEDIA server itself. (seeing itself)
    I don't see MEDIA when viewing Network on my Windows 8 laptop.  I can manually do \\MEDIA and the shares showup. (and then it shows up under Network on the left side)  If I close Explorer, it's not longer showing up again. (even after rebooting everything)
  • edited February 2013 Member
    If nobody has any ideas on the strange Computer Browser behavior above, I might re-instal 2012l from scratch again tomorrow.  It's not that hard and I haven't done much since the vanilla setup and adding drivepool.   I should see how the computer first shows up on the network post re-install BEFOREI add drivepool.   (unless someone has a better idea what's wrong) Worst  long term case I put on Windows 8 as my server, but I'd rather use 2012 for learning and best possible server performance.  (and better MyMovies add-on)
  • I'm learning more:  The following two threads might help me tackle the learning curve of 2012, I'll try not to hyjack this thread with unrelated problems.  :-/   need help though!
    "How Do I Make The Server Visible To Workgroup Computers?"
    "Accessing 2012 Essentials Without Being In Domain "

    2012 is looking pretty ugly first impressions so far, but I'm going to hang in there and see what I can do/learn to make it work the way I want.
  • Covecube
    2012 Essentials is on a domain, probably that's why it's not showing up on the local workgroup.

    I see the same thing over here.
  • edited February 2013 Member
    For people that want to run the connector, but don't want the client to be forced to auto join the domain, I found MS released a registry fix.

    The problem with that is, you'll be forced to type in the password every time you reboot to access shares.  It's not able to be saved "by design" as usual.

    This other power user went as far as writing up how to demote your server to workgroup, but it sounds like I'm opening up a can of worms. 

    Here's another interesting suggestion I wonder if the reverse is true?
    "Change the workgroup for the computers to match the "NetBIOS" name for the server's domain. (not the ****.local one). Then see if it shows up. "
    The OP said that actually worked for him as you can see.   Is their a way to just use WORKGROUP as the actual domain name for a re-install?  (I doubt it, probably won't be allowed)

    If I can't find a way to force 2012 essentials to play nice (free of using connector and joining domains, and losing the ability to save passwords for shares) than I'm ready to throw in the towel and use Windows 8 as my server OS!  
  • So as I said, on my 2012 server, "Computer Browser" services on MEDIA was disabled.  I started it and also set it to Automatic.  This allowed me to actually access my server if I manually type \\MEDIA while in my laptop.   The MEDIA computer name was not visible under networks in explorer though.

    I just renamed my windows 8 laptop workgroup  name from WORKGROUP to JAZJON.  (the same name as my Domain  name on 2012)    My server is now showing up under Network in explorer on my laptop like normal.   I wonder why it's not visibly listed before the name change. It's not like I actually joined the domain.  

    Is their any way around this?   Does anyone know if I can name my server domain "WORKGROUP" if I reinstall 2012? to make things seemly to anyone that wants to browse my server shares at my house?  I don't want to have to put every computer that comes through my house into the JAZJON workgroup.
  • I figured I'd chime in so far with my experiences with DP 2.0 beta on a Server 2012 Essentials Install. I'm in the process of migrating all the files over from the storage space to a new drive pool with one HDD, once all the files are moved over, I will delete the storage space and add all the drives to the DP.


    I'm also going to use the dpcmd command to enable folder level duplication as I don't want the entire Client Backup Folder duplicated. Finally I'm going to point Crashplan to resume my offsite backups to the newly created pool and hopefully that will all go smoothly. So far I've been using DP 1.3 oh a WHS 2011 box at home and it has been flawless. I even upgraded from 500gb to 2TB WD Red drives as Stablebit Scanner warned me of a couple of bad sectors on that drive and the migration went flawlessly.

    I'm running Plex, MyMovies, DNS Server, DHCP Server, WebDAV, StreamToMe, Crashplan and a few applications on the Home Server and never had a performance issue. Will keep everyone posted as to how the beta version is working out. Thanks for releasing this and I look forward to making another purchase if all goes well.

  • So far the migration has been flawless, the move folder command within the Dashboard worked flawlessly. One thing to note is when enabling duplication using the dpcmd executable, make sure you fire up the command prompt as an administrator, otherwise when trying to set the duplication level, you'll get an access denied response on certain folders. So far I'm liking the new interface even though it's relatively simplistic but the underlying capabilities on it are great.
  • So far I'm very impressed with the performance under server 2012 essentials. Under storage spaces I was getting something around 100mbytes per second read and a very slow 40mbytes per second write. Here are my results on an HP ex495 running 2 x wd 2tb red drives and an old Seagate 500gb drive. Core 2 duo with 2gb of ram. OS sits on an Intel x25-m g2 80gb ssd that's not in the pool.

    I don't know what you're doing with the file system level drivers but the performance is really great. Keep up the good work, if you add an intelligent sad caching algorithm in the future, I think you might have a great product on your hand for the enterprise world without having to drop a lot of money on a hardware raid based system that is extremely difficult to manage.

    CrystalDiskMark 3.0.2 x64 (C) 2007-2013 hiyohiyo
    Crystal Dew World :
    * MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

    Sequential Read : 181.500 MB/s
    Sequential Write : 144.698 MB/s
    Random Read 512KB : 71.689 MB/s
    Random Write 512KB : 149.474 MB/s
    Random Read 4KB (QD=1) : 1.089 MB/s [ 266.0 IOPS]
    Random Write 4KB (QD=1) : 2.430 MB/s [ 593.2 IOPS]
    Random Read 4KB (QD=32) : 2.959 MB/s [ 722.5 IOPS]
    Random Write 4KB (QD=32) : 2.476 MB/s [ 604.4 IOPS]

    Test : 100 MB [F: 25.5% (1070.2/4191.5 GB)] (x5)
    Date : 2013/02/10 14:24:48
    OS : Windows Server 2012 [6.2 Build 9200] (x64)
  • Thanks alot ajafar for all the updates... I am in the process of installing WSE2012 and have been keeping a close eye on this... looks like its time to start testing drivepool on my new server because storage spaces is too limited for me...

  • Has anyone been using DP 2.0 since it's release to this point without any data issues? I recently installed WS2012E with DP 2.0 with 2 test drives from my WHS2011 VM. So far all has been stable, but wanted to check in here before taking the plunge and moving all 20 of my drives over to WS2012E. Thanks in advance for your comments.
  • It's working great for me (20TB)  I've since switched from Server 2012 to Windows 8 though.  I've never lost a thing.   I have one tip though, since their is no recycle-bin if you delete something over the network by mistake, you can undelete it.   Just use the portable version of Recuva.
    (and run it on the hidden poolpart folder on each hard drive.  If I'm cleaning up folders and deleting stuff, I always try to do it via a remote desktop session for that very reason.   I've been using DrivePool since the early WHS 2011 v.1 days, it's always "Stable" :-)
Sign In or Register to comment.