Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Our Sites 


No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.

The new forum is at:

The new forum is running IP.Board and will be our primary forum from now on.

This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.

Thank you,

StableBit Disk Size Limit? BSOD

edited April 2013 in DrivePool
When I upgraded from WHS to WHS 2011 the first thing I did was buy and install StableBit and I haven't looked back. The performance has been great, and the product has been rock solid. My WHS 2011 box was leveraging six disks ranging in size from 500Gb to 1.5Tb for a total storage pool of around 4Tb.

Last week I purchased 3x 3Tb SATA III drives to replace some of the older/smaller disks in my pool. I didn't have enough available storage to remove more than one disk at a time from the pool, until I had at least one of the 3Tb drives installed. The initial disk installed and partitioned just fine (using the WHS 2011 Dashboard), added 2.74Tb to my pool, and WHS re-balanced my shares putting ~350Gb on the drive. When I rebooted however, Windows came up, I logged in, and about 5 minutes later got a BSOD. Every time the system rebooted, it threw a BSOD. I removed the disk and all went back to normal. Assuming I may have gotten a bad disk, I tried another, and ultimately all three produced exactly the same results.

I can connect these disks to my Windows 7 workstation and I have no issues at all, so I'm assuming that the issue is either a SATA controller issue, WHS 2011 issue, some undiagnosed hardware issue, or an issue with StableBit and the disk size. The motherboard is rather old, so I've gone the route of ordering a new one with SATA III capability onboard (eliminating the cheap SATA controller that I had purchased about a year ago), and I plan to rebuild the box on newer hardware.

Before I get the whole thing built and transfer my StableBit license over to the new machine, I figured I should confirm that there's no disk limitation within StableBit that could be causing my issue.

Additionally, is there anything special I have to do to transfer my StableBit license from the old box to the new one, and will I run into any issues running both simultaneously for the afternoon it'll take to move all of the data over?


  • I have EIGHT 3TB drives (24TB) running no problem.

    I would bet the new motherboard with built in SATA controller will fix all your problems.

    I doubt it's the drives since you tried 3 different ones.

    Using an old motherboard with 3rd party SATA controller sounds like the most potential for instability in my experiences. 

    Just run the NEW machine in Demo mode while you slowly transfer.  You get 30 days!   Deactivate the license on the old machine through the drivepool GUI.   Then plug the number into your new machine

  • Covecube
    It could be a weird combination of issues. Or it could be a faulty SATA driver, even.

    Either way, I think you should do this:
    And use the form to the dump. 
  • mvdmvd
    edited April 2013 Member
    Drivepool on latest .225 beta with

    8 x 4TB's in pool#1
    12 x 3TB's in pool#2

    Windows 2012 Enterprise.  Flawless.
  • Awesome, thanks for all the comments folks. New motherboard and such arrived today, so I'll give it a go this week.
Sign In or Register to comment.