Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google


No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.

The new forum is at:

The new forum is running IP.Board and will be our primary forum from now on.

This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.

Thank you,

Intermittent Error when copying data

edited August 2011 in DrivePool

I've rebuilding my server and copying back approx. 4TB of data from 6 HDDs.

During the process, I've been using SyncToy/GoodSync/... and on some files, keep getting an error which states that the device is not ready.

The majority of files are processed OK. If I repeat the sync job, it fails again on these specifc files. It fails in both SYncToy and GoodSync.

The weird thing is that when I try to sync to a non-pooled folder, it works fine and it also works fine if I manually select the files and do a copy / paste.

Very strange

any thoughts?


  • Sample of the error from AllWaySync :

    [5/08/2011 12:14 AM] File "Error while copying "I:\DE\shares\TV Series\The Ricky Gervais Show\Season 2\metadata\The Ricky Gervais Show - S02E04 - Onion.xml" to "\\homeserver\TV Series\The Ricky Gervais Show\Season 2\metadata\The Ricky Gervais Show - S02E04 - Onion.xml"" has been skipped by error-handling system, The device is not ready. (80070015), fs::movetodest::movefileex_failed
  • I have the same problem, i'm sure you are glad to hear. I'm hoping it has nothing to do with me swapping the sata cables around, which come off PCI cards.

    I've tried various instances to confirm its a specific server issue.

    It is.

    i've used SSD and mechanical HDDs, when copying to the servers shared folders.

    I've tried copying from win 7 64 ultimate, win 7 32 home, vista home premium and have used teracopy (preferred), copy handler and ultimate copier. All give the same results as described by 'ethanol'.

  • The weird thing is its not all files on a disk only some. But strangely if copied manually, they work.
  • edited August 2011 Member

    Exactly. If you group copy some files are skipped, and it will be the same files if you start the copy again.

    Error states 'Cannot find specified file', yet by checking that the file is complete and accessible, leaves me scratching my head.

    I have only tried copying to the server shares from a remote computer across the LAN, so later i'll see, by initiating the copy directly from the server, if it give a temporary work around.

  • edited August 2011 Member

    I'm having similar issues with random File Not Found errors.

    I've found that the easiest way for me to reproduce this is to use the My Movies add-in's Music Disc Copier- the copy process will fail when the copier encounters a file not found error when trying to access one of its temp files.  Here's an overview of the music copier settings to best reproduce the problem:

    • Target Format: WMA Lossless, 100% quality
    • Store on Music share (WHS default share, stored on DrivePool, duplicated)
    • Additional Mobile Format: MP3 (Target Type: Bitrate, Engine Quality High, Bitrate 160 average, auto VBR)
    • Store on LQ Music share (stored on DrivePool, non-duplicated)

    This configuration produces considerable processor load (my server has an Athlon II x3), with the mp3 encoder maxing-out one of the cores.  With this configuration, the copy process will fail almost every time.  It works just fine when writing to non-pooled shares.

  • Covecube
    Now that the drive health issues were addresses in 3262, I'm going to look at this next.

    Since it's the same file that's failing, perhaps long path related? I will test that as well.

    Now that the drive health issues were addresses in 3262, I'm going to look at this next.

    Since it's the same file that's failing, perhaps long path related? I will test that as well.

    In my case, it's not always the same file that fails, as these are temp files that the My Movies add-in generates as it rips music from a CD.  I think it may have more to do with processor and/or IO load during the ripping/encoding process.
  • Covecube
    I think I've got it reproduced.

    I believe it has to do with some internal privilege management and doesn't actually mean that the file is not found.
  • edited August 2011 Covecube
    This was a very intricate situation. There were actually 2 problems interacting together to cause these errors. I believe that both of these issues are fixed in build 3292, which is out now.

    The problems are kind of involved, so let me explain what was happening.

    Problem #1:

    The file not found errors were actually not being returned because a file was missing. Because of the new security implications of BETA M3, all I/O is now audited against the security context of the caller. So if user "Alex" is trying to create a file, DrivePool uses Alex's security token to issue the I/O calls. This works great because now Alex gets to be the owner of the new file and everything is fine and dandy.

    The problem is that DrivePool actually performs small pool management function when you create a new file or move a file. And these functions are operating using the Windows backup API. This is so that we can maintain everything about the file when we relocate it (alternate streams, security, attributes and modifications times). The problem is that the user "Alex" might not have the appropriate privileges to perform the minute pool management that's needed as part of the I/O call. As a strange consequence, a file not found error happened to be issued because of this.

    By the way, this error did not cause file corruption because it was failing BEFORE the new file got created and was correctly returning an error code to the caller (albeit a strange error code).

    Problem #2:

    As I said, one of the neat things that DrivePool does is it preserves the exact file / directory as it was at the source when it had to move it for pool management purposes. One of the pool management function that DrivePool performs is directory cloning.

    This comes into play when you are moving a file on the pool. If the move destination needs to go on a pool part that does not host the directory structure for a file, DrivePool will clone the directory structure from another pool part in order to preserve it exactly as it is over there. This is a recursive process that basically applies the file cloning routines to directories. There was a bug introduced into this routine (I believe in M3) that would issue a device not ready error to the caller, under some circumstances. This wouldn't happen every time so it was harder to catch.

    Again, no file corruption, the move would just fail and the file would remain at the source.

    Applications like RichCopy / SyncToy and probably many others tend to copy to a temp file first and then rename the file to its final name. That's probably why they were generating these errors.

    We have 2 concrete issues fixed. Let me know if this still continues and I'll look into it some more.
  • Looks like this resolved the issues I was having with the My Movies disk copier.  Thanks!

  • Seems to be working now - thanks
  • The problem is not completely solved, though greatly improved, thanks.

    Now for every TB copied across to the pool via the network, i sometimes get up to 10 files skipped - ' Target path specified not found'

    I use Teracopy, ver 2.12 NOT Ver 2.2 as 2.2 seems broken.

    Teracopy shows the skipped files, finding those skipped files and recopying always completes successfully.

    I've just tested to see if the source files path length is an issue. -Doesn't appear so. Tried 300+ characters

  • Another thing i've noticed is the intermittent hesitation the drive pool has when data is being copied to it, at first i thought it was at the end of each file copy but it also stops, momentarily, mid-file.
Sign In or Register to comment.