Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Our Sites 


No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.

The new forum is at:

The new forum is running IP.Board and will be our primary forum from now on.

This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.

Thank you,

WHS 2011 SP1 Client Back Up Service Failure

edited April 2013 in DrivePool

We are running WHS 2011 SP1 with Stablebit Drivepool 1.3.7541.  There have been occasional backup file corruptions since we moved from V1 to 2011.On 4/10 backups on all clients started to fail.  I tried restarting the service and cold reboots to no avail.  I followed the recommended steps on the Microsoft Tech site (repair tool, chkdsk...) none helped. The tech site did indicate that corrupted files can prevent the service from running backups.  So, looked through the logs and found that the service was failing due to an unexpected EOF on H:/ServerFolders\Client Backups\Commit.dat. (H: is the drivepool) These errors started showing in the log on 4/8, the day after I installed the latest version of DrivePool (1.3.7541). I tried to look at Commit.dat and found a 0K file.  So, I copied to another folder and deleted the original, hoping that WHS would rebuild on a reboot.  The fix appears to have worked, because now the file is 5K and after running the Backup Repair Tool again, the service is working.

At first I did not make any connection with the last update of Drivepool and the service failure.  However, there have been no other changes that would explain the problem. I did searches on the internet and here at Covecube.  The only reference is from dslabbekoorn where he lost files.  I am pleased the service is running again.  Manual backups completed and now I am waiting for the daily cycle to complete.  I would be grateful if someone could provide some insight.  Deleting control files is a pretty crude way to fix a service. 



  • edited April 2013 Member
    Same problem here. All backups are now failing. 

    I moved the WHS backups into a non-pooled drive and now they are working. Please fix this, thanks!
  • Ditto, for about 1.5 months now I have been getting constant corruption in my backups which forces me to delete them and start from scratch. I installed a new HDD and did not add it to the pool and I still go data base corruption so I am at a loss! 
  • Covecube
    All those that are experiencing the backup database corruption, do you have duplication enabled for the Backup folder?
  • yes, same thing here.
  • Covecube
    And I'm assuming that you haven't messed with the "config" file....
    Would you please use the "" form to submit the issue?
    And use to grab the logs from DrivePool, and attached them to the contact post.

    @Varroa: you're still getting client backup database corruption on the non-pooled drive? did you copy the old database over? Or started it from scratch? If from scratch and on the non-pooled drive, then this is an error with either the disk (sounds like you've ruled that out) or with the code for the Client Backup service.
  • New data base, brand new WD RED HDD, I am at a loss. There are a lot of people complaining about the same issue and nobody can seem to nail it down.
  • Covecube
    Varroa: if that's happening on a non-pooled disk, that's definitely something wrong with the client backup service.
    I can look at the log files for the backup service, if you want. I may be able to pinpoint what's going wrong even if I may not be able to do anything to fix it.  email me the "C:\ProgramData\Microsoft\Windows Server\Logs" folder (or at least all the log files that start with "backup"). My email is drashna (at)

    Also, if you're able to, head over to the MS Technet forums and make a post about it. 
  • Sorry for the late response, I will grab the logs tonight and fire them off to you. I think I searched at the MS Technet forums and didn't find an answer, just lots of complaints.
  • edited April 2013 Member
    Ok, I gave it one more shot last night. I noticed there were a bunch of log errors due to the Shadow volume service being unable to complete it's function during backups. So, I disabled shadow volume backups, deleted the backup  database, installed the GPT/Uefi hotfix, created a new storage pool just for backups using two brand new WD RED 2 TB drives, moved the backup folder to this new pool and ran my backups (I also disabled perfect disk from running on the new pool, just in case). I managed to back up 1 computer but the second one was unable to finish (due to time constraints and the size of that backup) but I also got database corruption again! Drashna, if you don't mind I will send you my logs tonight, thanks.
  • Hi,

    I have had my client backups running fine for over a year whs11 + dp they have been problems in the past this is how I got my backups to work

    Used the standard folder and made a full backup of all client pc's then once that had finished used the dashboard interface to move the backup folder to the pool since I did that everthing has been fine I even have duplication on.

    I currently have a 36tb pool I do plan to create a new pool in the future just for backups but I don't have time at the moment to do it try the above see if it works for you it did me

  • Cross my fingers but I think I figured it out. I have had 3 days of backups now and no problems. I re-checked the shadow copies settings and even though I had SC disabled for all drives, it still showed one drive as using 0 MB for shadow copies (all other drives showed no value at all). I re-enabled shadow copies on that drive and then disabled it and the 0 MB value disappeared. I think the drive was still trying to do shadow copies (even though it was disabled and had no space allotted for it) which is what was causing all my problems. We will have to wait and see.
  • Covecube
    Like I said at We Got Served forums, a) I'm glad it sounds like you fixed it!, and b) it sounds like the shadow copy service corrupted the snapshots on that volume, and is probably why the issues occurred.
  • AAARRGGHHH!! I got corruption again last night. This is the log error I am getting now:

    The Windows Server Client Computer Backup Service failed at (1223) of (e:\colorado_qfe_fast\backup\pc\util\sort.cpp).
  • and

    Faulting application name: WSSBackup.exe, version: 6.1.8800.16402, time stamp: 0x5115af6a
    Faulting module name: WSSBackup.exe, version: 6.1.8800.16402, time stamp: 0x5115af6a
    Exception code: 0xc0000025
    Fault offset: 0x00000000000915e5
    Faulting process id: 0x1c4
    Faulting application start time: 0x01ce42160b786be4
    Faulting application path: C:\Program Files\Windows Server\Bin\WSSBackup.exe
    Faulting module path: C:\Program Files\Windows Server\Bin\WSSBackup.exe
    Report Id: 8eb771a6-afbe-11e2-a6c2-001b212ea086
  • Covecube
    If you haven't tried it already... try using backup on a physical HDD, and not the pool at all. If you have already and that still doesn't help.... 

    I've found a thread that may help. But it's basically a step or two away from reinstalling, basically:
  • edited April 2013 Member
    I tried backing up to a single drive with no luck. I will take a look at the post and see if it helps. Otherwise I think you are right and I need to nuke the install. 
  • Covecube
    If you've already looked at that post, you'll see it's basically a step or two away from nuking it anyways. :(

    Sorry that we couldn't find a better solution. Though, I'd recommend signing up, and making a post at, or sign up and post a bug at
    If only to make sure that Microsoft is aware of the issue.
  • edited May 2013 Member
    Ok, I just finished a complete re-install of the OS. Before I did that I did some hardware tweaking and while running memtest on the ram I found errors after about 20 mins (using mulitple different configurations with 1 to 4 sticks). The ram tested fine in another machine before I installed it and it still test fine in that other machine so it must be a incompatibility issue with the current motherboard. I put in some other ram I had laying around (and ran memtest successfully) I have run backups for two nights without problems now so I hope the ram was the cause. I will keep you posted.
  • Finally gave up on WHS2011, kept getting problems such as backup failures after 2 re-installs.  The pool was ok throughout.  Got a liscense for Windows server 2012 essentials and a copy of "Windows Server 2012 Essentials -Step by Step" from Wegotserved. (Highly recommended if you are upgrading) Everything is back and running just fine, backups work without a hiccup and the pool came back up as if it never left.  Just have to add Lightsout and my new 3TB drive and I'll be back to square one again.   Not sure where the problems we were all having came from, but they are gone now (knock on wood)  Ran Memtest on my RAM after Varroa's comment and it all came out OK, so that was not my problem.  Hope this gets straightened out soon.  Good luck all.
  • Covecube
    Well, I know there has been several updates/patches to the Client Backup engine. And then there is the recent "GPT" hotfix. (adds GPT support for client computers).

    WS2012E is a great OS, if you have the money for it. And We Got Served is a great resource too. I know, I've been a large contributor to the site (as well as the lead mod at the forums there). 
  • It still could be the RAM. I suffered with this problem for over a year. MemTest86 would pass every time. Finally when it became a constant problem MemTest86 failed. I replaced the RAM and database has been rock solid ever since.

  • Covecube
    Very true. Also, if there is any compatibility issues between the board and RAM, or if it's running at the wrong voltage or.... you get the idea.
  • Member
    Backups have been running for a week now without any problems. Either the re-install fixed the problem or the ram was at fault. I did have a Seagate LP drive drop out of the pool/machine already (only had about 1 year of use on it) so that is strange. It wasn't failing any health scans so I just removed it for now. Thanks for all the help everybody.
  • Covecube
    Varroa: not every issue with drives will show up. If there is an issue with the circuit board on the drive itself... you can get all sorts of weird issues. Or it can just outright fail.  So it could be possible that the drive was causing the issue too....  That's why I hate hardware issues, they're a real PITA to track down, as they can be ANYTHING.

    But glad to hear that the issue hasn't come back.
  • I have had my Seagate 3TB drives drop out intermittently. It happens very seldom but it doses happen. A cold boot fixes the problem.
Sign In or Register to comment.