Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

Our Sites 


No poll attached to this discussion.

In order to better support our growing community we've set up a new more powerful forum.

The new forum is at:

The new forum is running IP.Board and will be our primary forum from now on.

This forum is being retired, but will remain online indefinitely in order to preserve its contents. This forum is now read only.

Thank you,

HELP- No access on shared folder after migration from M3 to M4!!!

edited January 2012 in DrivePool


I migrate my WHS 2011 stable bit addin from M3 to M4 following give  instruction:


  1. Download the wssx file to the server or to a connected computer.
  2. Run the wssx installer by double clicking on the file.
  3. Restart the Dashboard if it's open.
  4. Go to the StableBit DrivePool tab and press the migrate button to convert the pool to the new format."

After migration all share are not accessible (the device is not ready). I have a new drive "E:" with all files but shares point to c:\serverfolder\xxxx. The problem is that I cannot move from c: to e: (I riceive an exception and there is a rollback).

The only solution is to create a new share (eg MyMusic) that point to E: but I cannot remove the c:\serverfolder\music.

Thank you very much.




  • I have the same problem... It looks like the junction points did not get move over.

    Alex, can you help?
  • edited January 2012 Member
    I just posted in the M4 migration test thread before I saw this...  anyway, I had the same problem, here's how I fixed it with instructions from Alex (You'll do this from the new "pool" drive that was formed):

    You can simply right click on the folders in the pool root, go to properties and share them.


    Click Advanced Sharing -> Click "Share this folder".

    Before clicking ok, click "Permissions" and make sure allow "Full Control" is checked.

    You should do this for each folder that was not correctly re-shared.
  • Is there a registry
    key or other to edit to correct the wrong share to the right path?
  • you can also do it in the registry, but the above works much better! (I did it the registry way the first time...before I got the above from Alex)
  • BOOM! That fixed it, thanks ajuhawk and Alex!
  • I edited this reg key HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\LanmanServer\Shares and now it seems working!! On some subfolder I have some permission problem and I'm investigating right now!!

    Than you all!!

  • Covecube
    I've seen a few of these. Seems like Windows is refusing to un-share the old shares sometimes. In this case, everything else gets migrated, except that the new folders don't get shared.

    The simple solution is to just re-share the folders on the pool (after getting rid of the old shares).

    Here's the full procedure for this:

  • Thank you Alex for providing M4 !

    First impression, WHS is more responsive when accessing files.  I will do more testing in the coming days. 

    For the migration from M3 to M4 I had to use your supplied instructions to get my shares back.  The first time I started the Dashboard and clicked "Migration", I got a eror message saying that it could not migrate my first share... Take note that I am using M3 since the very beginning and I had the sharing issues in the past.

    That was part of the deal using BETA 
  • edaeda
    edited January 2012 Member
    Clearly I'm having the problem described above.  However, as I try to follow step 2 (stop sharing folder in the Share list under Computer Management), I get the "Error 3:  The system cannot find the path specified."

    The path is there (C:\ServerPool\ServerFolders\Pictures, for example), however, the folder has the shortcut icon, but the properties do not show a shortcut--just the normal folder properties.  Attempting to open the folder gives an error about the location being unavailable.

    So, at this point, I am unable to repair the share pointers and make them work as expected.  Any advice?

    Edit:  I may have found a work around.  I am able to rename the folder at c:\ServerPool\ServerFolders\<whatever> to something else.  I then create a new folder in the same location with the original name.  At that point, I can remove the share and create a new share on D:\.  I have done this with 4 shares and am waiting for Pool Condition and Indexing to complete before I go further.

    I am waiting because at this point, DrivePool reports that each of the folders are 0B in length, which I know to be incorrect, so I'll wait for it to work it out and see what happens.

    Edit2:  The workaround seemed to, well, work around just fine.  All folders and permissions have been set and all seems to be in place.  Remeasure seems to have provided real numbers on the data size.  Duplicating is moving forward for some reason.  

    I do have the backup corruption problem others have mentioned.  I'll work on that tomorrow....
  • You have to disconnect all the external devices that could use the share folders like Homegroup, network folders to your computer library, or shortcut folders, or media player like Boxee and etc., then restart your server, and continue Alex instructions of how to restore and index your share folders. M4 is rock solid and speed on my HP EX485. I have no problem with both Boxee box and WD TV Plus. I'm still having a problem on client back up in the pool with M3, hopefully M4 will take care the issue. Thanks Alex.
  • I used the workaround mentioned by eda above.  I had the same problem, it worked (except for some random subfolders)- just took a while.
Sign In or Register to comment.